If you have registered and purchased access to your community, you should have full access to it when you login to your Packback account. However, if your profile is not showing that any communities exist, there are a few reasons this may be happening.

You are not logged into the account you purchased access with

It's possible you have two accounts and are not logged into the account that you purchased access with. Try logging in with a different email address! If need be, you can check through your email inbox(es) and find any email from us to confirm which account you should login to. When in doubt, it’s usually your school email!

You haven't registered for the community yet

Keep in mind that in order to access your community and begin posting, you will need to have completed registration first. You can go about this one of two ways: via registration email or Community Lookup Key. Take a look at this article to learn how to do that!

If you can see your community, but are unable to post in the community feed, you still need to complete registration!  In this case, all you have to do is login to your account and go to the Join a Community page where you will be prompted on how to complete registration and purchase access to your community!

Still having trouble?

If you're finding yourself stuck and unable to resolve this issue, feel free to hit up our Support Team through this Request Form and someone will help point you in the right direction?

Was this article helpful?
0 out of 9 found this helpful

Still have questions? We're here to help.

If you can’t find the answer you are looking for, please reach out to Packback’s team! Our team is eager to help, speedy to reply, and available 7-days a week. Let us know how we can support you!

Submit a request Or email help@packback.co